Vulnerabilities / Threats

11/22/2017
01:03 PM
Connect Directly
Google+
Twitter
RSS
E-Mail
50%
50%

Intel Firmware Flaws Found

Another big firmware security issue affecting Intel processors, requires OEM updates.

US-CERT yesterday issued an alert in response to newly discovered vulnerabilities in Intel's Management Engine (ME), Server Platform Services (SPS), and Trusted Execution Engine (TXE) firmware that could allow an attacker to wrest control of machines running Intel processors.

According to Intel, its processors affected by the vulns are: 

  • 6th, 7th & 8th Generation Intel Core Processor Family
  • Intel Xeon Processor E3-1200 v5 & v6 Product Family
  • Intel Xeon Processor Scalable Family
  • Intel Xeon Processor W Family
  • Intel Atom C3000 Processor Family
  • Apollo Lake Intel Atom Processor E3900 series
  • Apollo Lake Intel Pentium
  • Celeron N and J series Processors

Researchers with Positive Technologies Research initially found the vulnerabilities in the ME and reported them to Intel. The researchers say they will provide more details on their findings during their presentation at Black Hat Europe next month.

"Intel ME is at the heart of a vast number of devices worldwide, which is why we felt it important to assess its security status. It sits deep below the OS and has visibility of a range of data, everything from information on the hard drive to the microphone and USB," said Maxim Goryachy, researcher at Positive Technologies. "Given this privileged level of access, a hacker with malicious intent could also use it to attack a target below the radar of traditional software-based countermeasures such as anti-virus."

Intel, meanwhile, said the flaws could allow an attacker to "impersonate" ME, SPS or TXE, and therefore compromise the machine's security; run code unnoticed by the user or the operating system, and to crash a system or cause "instability" to it.

The chip manufacturer advises checking with OEMs to get a firmware update, and released a downloadable tool to determine whether a machine contains the vulns. "Intel highly recommends checking with your system OEM for updated firmware," the company wrote in its security advisory.

This is the second major firmware vulnerability issue for Intel this year. In early May, the company disclosed a critical privilege-escalation bug in its Active Management Technology (AMT) firmware used in many Intel chips that affected AMT firmware versions dating back to 2010.

That vulnerability, which was discovered by security firm Embedi, could allow an attacker to remotely delete or reinstall the operating system, control the mouse and keyboard, and execute malware on the machine. Intel patched the bug in a firmware update, but like the latest firmware finding, it was up to OEMs to issue it to users.

Related Content:

Join Dark Reading LIVE for two days of practical cyber defense discussions. Learn from the industry’s most knowledgeable IT security experts. Check out the INsecurity agenda here.

Kelly Jackson Higgins is Executive Editor at DarkReading.com. She is an award-winning veteran technology and business journalist with more than two decades of experience in reporting and editing for various publications, including Network Computing, Secure Enterprise ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
White House Cybersecurity Strategy at a Crossroads
Kelly Jackson Higgins, Executive Editor at Dark Reading,  7/17/2018
The Fundamental Flaw in Security Awareness Programs
Ira Winkler, CISSP, President, Secure Mentem,  7/19/2018
Register for Dark Reading Newsletters
White Papers
Video
Cartoon Contest
Current Issue
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2018-14492
PUBLISHED: 2018-07-21
Tenda AC7 through V15.03.06.44_CN, AC9 through V15.03.05.19(6318)_CN, and AC10 through V15.03.06.23_CN devices have a Stack-based Buffer Overflow via a long limitSpeed or limitSpeedup parameter to an unspecified /goform URI.
CVE-2018-3770
PUBLISHED: 2018-07-20
A path traversal exists in markdown-pdf version <9.0.0 that allows a user to insert a malicious html code that can result in reading the local files.
CVE-2018-3771
PUBLISHED: 2018-07-20
An XSS in statics-server <= 0.0.9 can be used via injected iframe in the filename when statics-server displays directory index in the browser.
CVE-2018-5065
PUBLISHED: 2018-07-20
Adobe Acrobat and Reader 2018.011.20040 and earlier, 2017.011.30080 and earlier, and 2015.006.30418 and earlier versions have a Use-after-free vulnerability. Successful exploitation could lead to arbitrary code execution in the context of the current user.
CVE-2018-5066
PUBLISHED: 2018-07-20
Adobe Acrobat and Reader 2018.011.20040 and earlier, 2017.011.30080 and earlier, and 2015.006.30418 and earlier versions have an Out-of-bounds read vulnerability. Successful exploitation could lead to information disclosure.