Vulnerabilities / Threats

11/22/2017
01:03 PM
Connect Directly
Google+
Twitter
RSS
E-Mail
50%
50%

Intel Firmware Flaws Found

Another big firmware security issue affecting Intel processors, requires OEM updates.

US-CERT yesterday issued an alert in response to newly discovered vulnerabilities in Intel's Management Engine (ME), Server Platform Services (SPS), and Trusted Execution Engine (TXE) firmware that could allow an attacker to wrest control of machines running Intel processors.

According to Intel, its processors affected by the vulns are: 

  • 6th, 7th & 8th Generation Intel Core Processor Family
  • Intel Xeon Processor E3-1200 v5 & v6 Product Family
  • Intel Xeon Processor Scalable Family
  • Intel Xeon Processor W Family
  • Intel Atom C3000 Processor Family
  • Apollo Lake Intel Atom Processor E3900 series
  • Apollo Lake Intel Pentium
  • Celeron N and J series Processors

Researchers with Positive Technologies Research initially found the vulnerabilities in the ME and reported them to Intel. The researchers say they will provide more details on their findings during their presentation at Black Hat Europe next month.

"Intel ME is at the heart of a vast number of devices worldwide, which is why we felt it important to assess its security status. It sits deep below the OS and has visibility of a range of data, everything from information on the hard drive to the microphone and USB," said Maxim Goryachy, researcher at Positive Technologies. "Given this privileged level of access, a hacker with malicious intent could also use it to attack a target below the radar of traditional software-based countermeasures such as anti-virus."

Intel, meanwhile, said the flaws could allow an attacker to "impersonate" ME, SPS or TXE, and therefore compromise the machine's security; run code unnoticed by the user or the operating system, and to crash a system or cause "instability" to it.

The chip manufacturer advises checking with OEMs to get a firmware update, and released a downloadable tool to determine whether a machine contains the vulns. "Intel highly recommends checking with your system OEM for updated firmware," the company wrote in its security advisory.

This is the second major firmware vulnerability issue for Intel this year. In early May, the company disclosed a critical privilege-escalation bug in its Active Management Technology (AMT) firmware used in many Intel chips that affected AMT firmware versions dating back to 2010.

That vulnerability, which was discovered by security firm Embedi, could allow an attacker to remotely delete or reinstall the operating system, control the mouse and keyboard, and execute malware on the machine. Intel patched the bug in a firmware update, but like the latest firmware finding, it was up to OEMs to issue it to users.

Related Content:

Join Dark Reading LIVE for two days of practical cyber defense discussions. Learn from the industry’s most knowledgeable IT security experts. Check out the INsecurity agenda here.

Kelly Jackson Higgins is Executive Editor at DarkReading.com. She is an award-winning veteran technology and business journalist with more than two decades of experience in reporting and editing for various publications, including Network Computing, Secure Enterprise ... View Full Bio

Comment  | 
Print  | 
More Insights
Comments
Newest First  |  Oldest First  |  Threaded View
Weaponizing IPv6 to Bypass IPv4 Security
John Anderson, Principal Security Consultant, Trustwave Spiderlabs,  6/12/2018
'Shift Left' & the Connected Car
Rohit Sethi, COO of Security Compass,  6/12/2018
Microsoft Fixes 11 Critical, 39 Important Vulns
Kelly Sheridan, Staff Editor, Dark Reading,  6/12/2018
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2018-1060
PUBLISHED: 2018-06-18
python before versions 2.7.15, 3.4.9, 3.5.6 and 3.7.0 is vulnerable to catastrophic backtracking in pop3lib's apop() method. An attacker could use this flaw to cause denial of service.
CVE-2018-1090
PUBLISHED: 2018-06-18
In Pulp before version 2.16.2, secrets are passed into override_config when triggering a task and then become readable to all users with read access on the distributor/importer. An attacker with API access can then view these secrets.
CVE-2018-1152
PUBLISHED: 2018-06-18
libjpeg-turbo 1.5.90 is vulnerable to a denial of service vulnerability caused by a divide by zero when processing a crafted BMP image.
CVE-2018-1153
PUBLISHED: 2018-06-18
Burp Suite Community Edition 1.7.32 and 1.7.33 fail to validate the server certificate in a couple of HTTPS requests which allows a man in the middle to modify or view traffic.
CVE-2018-12530
PUBLISHED: 2018-06-18
An issue was discovered in MetInfo 6.0.0. admin/app/batch/csvup.php allows remote attackers to delete arbitrary files via a flienamecsv=../ directory traversal. This can be exploited via CSRF.