Risk
6/4/2009
03:39 PM
Connect Directly
Google+
Twitter
RSS
E-Mail
50%
50%

Hacking Tool Lets A VM Break Out And Attack Its Host

'Cloudburst' memory-corruption exploit released with Immunity's new version of Canvas penetration testing software

Researchers for some time have demonstrated the possibility of one of virtualization's worst nightmares -- a guest virtual machine (VM) infiltrating and hacking its host system. Now another commercial tool is offering an exploit that does exactly that.

The newest version of Immunity's Canvas commercial penetration testing tool, v6.47, includes the so-called Cloudburst attack module, which was developed by Immunity researcher Kostya Kortchinsky to exploit a VMWare vulnerability (CVE-2009-1244) in VMware Workstation that lets a user or attacker in a "guest" VM break into the actual host operating environment. VMware issued a patch for the bug in April.

"Companies and administrators tend to trust that breaking out of a VM is not possible," says Nick Selby, director of the enterprise security practice at The 451 Group. "A lot of people consider this to be just another proof-of-concept. They don't understand that is a commercially available exploit."

Even though VMware has issued a patch, many enterprises may not necessarily have implemented it, Selby says. "We know that people don't patch," he adds.

Immunity's VM "breakout" exploit follows that of Core Security Technologies' VMware Shared Folders exploit in its Impact penetration testing tool announced last year. The module "weaponized" a vulnerability discovered by Core that lets an attacker create or alter executable files on the Windows host OS. For the attack to work, VMware's Shared Folders feature must be enabled and at least one folder on the underlying host system must be configured to share files with the VM.

Selby says Cloudburst is a more significant hack because it's a memory corruption-based method that lets an attacker access more of the system and do more damage. "This is memory corruption," he says. And Cloudburst works with default VM settings, such as having VM tools installed, he says.

The attack entails the guest VM executing malicious code on the host, and then tunnels a connection to it. VMWare Version 6.5.0 and 6.5.1 are affected, as well as all host operating systems, including Linux.

But there are simpler virtual machine "escape" methods than Cloudburst, notes HD Moore, creator of Metasploit and director of security architecture for BreakingPoint Systems. "There are some easy escape methods -- the host file system directory traversal -- that don't require exploit tools...you can abuse it from a standard shell," Moore says.

Moore says this type of attack is most worrisome for organizations that run disparate systems on the same VM host. That would mean "the cloud model where you are running systems for two unrelated customers on the same hardware, and you're concerned about an attack on one gaining access to the other," he says.

Have a comment on this story? Please click "Discuss" below. If you'd like to contact Dark Reading's editors directly, send us a message. Kelly Jackson Higgins is Executive Editor at DarkReading.com. She is an award-winning veteran technology and business journalist with more than two decades of experience in reporting and editing for various publications, including Network Computing, Secure Enterprise ... View Full Bio

Comment  | 
Print  | 
More Insights
Register for Dark Reading Newsletters
White Papers
Cartoon
Current Issue
Dark Reading Must Reads - September 25, 2014
Dark Reading's new Must Reads is a compendium of our best recent coverage of identity and access management. Learn about access control in the age of HTML5, how to improve authentication, why Active Directory is dead, and more.
Flash Poll
Video
Slideshows
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2003-1598
Published: 2014-10-01
SQL injection vulnerability in log.header.php in WordPress 0.7 and earlier allows remote attackers to execute arbitrary SQL commands via the posts variable.

CVE-2011-4624
Published: 2014-10-01
Cross-site scripting (XSS) vulnerability in facebook.php in the GRAND FlAGallery plugin (flash-album-gallery) before 1.57 for WordPress allows remote attackers to inject arbitrary web script or HTML via the i parameter.

CVE-2012-0811
Published: 2014-10-01
Multiple SQL injection vulnerabilities in Postfix Admin (aka postfixadmin) before 2.3.5 allow remote authenticated users to execute arbitrary SQL commands via (1) the pw parameter to the pacrypt function, when mysql_encrypt is configured, or (2) unspecified vectors that are used in backup files gene...

CVE-2014-2640
Published: 2014-10-01
Cross-site scripting (XSS) vulnerability in HP System Management Homepage (SMH) before 7.4 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.

CVE-2014-2641
Published: 2014-10-01
Cross-site request forgery (CSRF) vulnerability in HP System Management Homepage (SMH) before 7.4 allows remote authenticated users to hijack the authentication of unspecified victims via unknown vectors.

Best of the Web
Dark Reading Radio
Archived Dark Reading Radio
Chris Hadnagy, who hosts the annual Social Engineering Capture the Flag Contest at DEF CON, will discuss the latest trends attackers are using.