Risk
4/24/2013
11:05 AM
Connect Directly
RSS
E-Mail
50%
50%
Repost This

Java Flaw Targeted By Crimeware Toolkit: Patch Now

Don't wait on this update, Java 7 users. Exploit uses bug, patched by Oracle last week, to execute arbitrary code.

Java 7 users: Have you updated to the latest version of the software, released last week by Oracle?

Anyone who isn't using Java 7 update 21, released last Tuesday, is at risk of being exploited via active attacks that target one or more Java browser plug-in vulnerabilities patched by Oracle.

Related attacks began Sunday, according to a brief research note published by security firm F-Secure. That's just five days after Oracle released the update, which included fixes for 42 vulnerabilities -- 39 of which could be remotely exploited without authentication -- as well as a new malicious Java application warning system.

One of the patched vulnerabilities (CVE-2013-2423) could be used to disable the Java security manager and run arbitrary code outside of the Java sandbox, according to Jeroen Frijters, the lead developer of the IKVM.NET project -- which maintains a Java virtual machine implemented in .NET. Frijters advertises himself as an "accidental security researcher."

[ Learn why security experts say Oracle is making good decisions. Read Oracle Delays Java 8 To Improve Java 7 Security. ]

By Saturday, an exploit for the flaw discovered by Frijters had been added to the open source vulnerability testing toolkit Metasploit, in the form of a new module.

"The vulnerability affects Java version 7u17 and earlier," said security researcher Eric Romang in a blog post. "This exploit doesn't bypass click-to-play, so the user must accept the java warning in order to run the malicious applet."

To date, the vulnerability appears to have been targeted via one or more crimeware exploits kits, but it's not yet clear which ones. F-Secure anti-malware analyst Timo Hirvonen Tuesday tweeted: "New Java exploit for CVE-2013-2423 has been introduced to RedKit."

But shortly thereafter, he noted that "it seems our automation identified the kit incorrectly" and tweeted: "We still need to work on identifying the exploit kit that introduced CVE-2013-2423. Looks like it might be CrimeBoss instead of RedKit."

CrimeBoss is an exploit toolkit that, after being loaded onto a website that's been compromised by an attacker, attempts to infect website visitors via malicious iFrames. While the toolkit is designed to exploit Java vulnerabilities "by faking the Java(TM) Platform SE Auto Updater," according to the Malware Must Die! blog, "even without Java you can get infected too."

RedKit, meanwhile, is a Russian-language toolkit that competes with the BlackHole and Phoenix crimeware packs, and which has often been loaded up with the latest Java exploits by its developers. RedKit is loaded onto compromised websites and targets browsers via drive-by attacks. The toolkit was used in February, for example, to infect visitors to the NBC.com website with malware such as Citadel.

Despite the release of Java 7 update 21 last week and fixes for dozens of bugs, Adam Gowdiak, CEO of Polish security research firm Security Explorations, said Monday that he'd already discovered a new, exploitable vulnerability in the update, which affects both the Java browser plug-in client as well as the all-new Server Java Runtime Environment (JRE).

According to the security firm's vendor status website page, two other flaws that the company reported to Oracle -- backed with proof-of-concept exploit code -- in the past two months are being "fixed in main codeline" or are still under investigation.

People are your most vulnerable endpoint. Make sure your security strategy addresses that fact. Also in the new, all-digital How Hackers Fool Your Employees issue of Dark Reading: Effective security doesn't mean stopping all attackers. (Free registration required.)

Comment  | 
Print  | 
More Insights
Register for Dark Reading Newsletters
White Papers
Flash Poll
Current Issue
Video
Slideshows
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2011-3154
Published: 2014-04-17
DistUpgrade/DistUpgradeViewKDE.py in Update Manager before 1:0.87.31.1, 1:0.134.x before 1:0.134.11.1, 1:0.142.x before 1:0.142.23.1, 1:0.150.x before 1:0.150.5.1, and 1:0.152.x before 1:0.152.25.5 does not properly create temporary files, which allows local users to obtain the XAUTHORITY file conte...

CVE-2013-2143
Published: 2014-04-17
The users controller in Katello 1.5.0-14 and earlier, and Red Hat Satellite, does not check authorization for the update_roles action, which allows remote authenticated users to gain privileges by setting a user account to an administrator account.

CVE-2014-0036
Published: 2014-04-17
The rbovirt gem before 0.0.24 for Ruby uses the rest-client gem with SSL verification disabled, which allows remote attackers to conduct man-in-the-middle attacks via unspecified vectors.

CVE-2014-0054
Published: 2014-04-17
The Jaxb2RootElementHttpMessageConverter in Spring MVC in Spring Framework before 3.2.8 and 4.0.0 before 4.0.2 does not disable external entity resolution, which allows remote attackers to read arbitrary files, cause a denial of service, and conduct CSRF attacks via crafted XML, aka an XML External ...

CVE-2014-0071
Published: 2014-04-17
PackStack in Red Hat OpenStack 4.0 does not enforce the default security groups when deployed to Neutron, which allows remote attackers to bypass intended access restrictions and make unauthorized connections.

Best of the Web