Risk
1/31/2011
09:29 PM
George V. Hulme
George V. Hulme
Commentary
50%
50%

Data Leak Vulnerability In Android Gingerbread

Google's Android Gingerbread (version 2.3) operating system is affected by a data-leak vulnerability that is very similar to a vulnerability in an earlier version that was supposed to have been fixed.

Google's Android Gingerbread (version 2.3) operating system is affected by a data-leak vulnerability that is very similar to a vulnerability in an earlier version that was supposed to have been fixed.Xuxian Jiang, a security researcher at NC State University has found a vulnerability in the most recent version of Google Android known as Gingerbread. According to Jiang, the data stealing vulnerability is similar to a vulnerability identified in Google's previous mobile operating system, Froyo.

Essentially, by enticing a user to click on a link, some information on the phone may be accessed. One of the more egregious aspects of the flaw is how it allows an attacker to potentially access files stored on the microSD card. Users can store virtually information they desire on the cards.

According to Jiang's post, there is working code that proves the vulnerability is exploitable:

We have a proof-of-concept exploit with a stock Nexus S phone and are able to successfully exploit the vulnerability to steal potentially personal information from the phone. The attack works by requiring the user to visit a malicious link. Based on the experiments with one of our Nexus S phones, we have leveraged the vulnerability to

• Obtain the list of applications that are currently installed in the phone; • Upload the applications (located in /system and /sdcard partitions) to a remote server;

Read and upload the contents of any file (including photos, saved voicemails...) stored on the phone's /sdcard. Note that to do that, the exact pathname/filename needs to be known.

So far there have been no indication of attacks in the wild.

A Google representative provided Dark Reading a statement that substantiated the researcher's findings:

"We've incorporated a fix for an issue in the Android browser on a limited number of devices that could, under certain circumstances, allow for accessing application and other types of data stored on the phone. We're in communication with our partners."

Until the fix is out, Jiang advises users who want to mitigate the risk to disable Javascript, or switch to another browser such as Firefox.

For my security and technology observations throughout the day, find me on Twitter.

Comment  | 
Print  | 
More Insights
Register for Dark Reading Newsletters
White Papers
Cartoon
Current Issue
Flash Poll
Video
Slideshows
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2013-6501
Published: 2015-03-30
The default soap.wsdl_cache_dir setting in (1) php.ini-production and (2) php.ini-development in PHP through 5.6.7 specifies the /tmp directory, which makes it easier for local users to conduct WSDL injection attacks by creating a file under /tmp with a predictable filename that is used by the get_s...

CVE-2014-9652
Published: 2015-03-30
The mconvert function in softmagic.c in file before 5.21, as used in the Fileinfo component in PHP before 5.4.37, 5.5.x before 5.5.21, and 5.6.x before 5.6.5, does not properly handle a certain string-length field during a copy of a truncated version of a Pascal string, which might allow remote atta...

CVE-2014-9653
Published: 2015-03-30
readelf.c in file before 5.22, as used in the Fileinfo component in PHP before 5.4.37, 5.5.x before 5.5.21, and 5.6.x before 5.6.5, does not consider that pread calls sometimes read only a subset of the available data, which allows remote attackers to cause a denial of service (uninitialized memory ...

CVE-2014-9705
Published: 2015-03-30
Heap-based buffer overflow in the enchant_broker_request_dict function in ext/enchant/enchant.c in PHP before 5.4.38, 5.5.x before 5.5.22, and 5.6.x before 5.6.6 allows remote attackers to execute arbitrary code via vectors that trigger creation of multiple dictionaries.

CVE-2014-9709
Published: 2015-03-30
The GetCode_ function in gd_gif_in.c in GD 2.1.1 and earlier, as used in PHP before 5.5.21 and 5.6.x before 5.6.5, allows remote attackers to cause a denial of service (buffer over-read and application crash) via a crafted GIF image that is improperly handled by the gdImageCreateFromGif function.

Dark Reading Radio
Archived Dark Reading Radio
Good hackers--aka security researchers--are worried about the possible legal and professional ramifications of President Obama's new proposed crackdown on cyber criminals.