Risk

2/11/2010
06:18 PM
Connect Directly
Google+
LinkedIn
Twitter
RSS
E-Mail
50%
50%

Adobe Flash, Reader, Acrobat Vulnerable

The company has issued fixes for two vulnerabilities, but a third set of flaw affecting Reader and Acrobat won't be patched until next week.

Adobe on Thursday issued two security bulletins to address vulnerabilities in its Flash Player software and in its LiveCycle and ColdFusion software.

It also issued a security advisory about vulnerabilities in its Reader and Acrobat software that will be addressed in a patch next week.

The Flash Player vulnerability is designated "critical" and affects version 10.0.42.34 and earlier. Flash Player 10.0.45.2 resolves the issue and is available for download.

The vulnerability affecting LiveCycle 9.0, 8.2.1 and 8.0.1, and ColdFusion 9.0, 8.0.1, 8.0 and 7.0.2, resides in the BlazeDS 3.2 component, or earlier, and has been rated "important." Adobe has posted fix details on its Web site.

Adobe's advisory warns of "critical" flaws in Reader 9.3 for Windows, Macintosh and UNIX, Acrobat 9.3 for Windows and Macintosh, and Reader 8.2 and Acrobat 8.2 for Windows and Macintosh.

"This vulnerability (CVE-2010-0186) could subvert the domain sandbox and make unauthorized cross-domain requests," Adobe's advisory says.

Adobe plans to make a fix available on February 16.

The vulnerabilities come at an awkward time for Adobe. This is the third month in a row that the company has issued critical security advisories for its Reader and Acrobat software. Its Flash technology was recently panned by Apple CEO Steve Jobs, who reportedly said that when Macs crash, Flash is usually the cause.

Adobe CTO Kevin Lynch posted a lengthy defense of his company's technology and, following a flurry of critical comments from readers, continued that defense in an additional comment post.

"I can tell you that we don't ship Flash with any known crash bugs, and if there was such a widespread problem historically Flash could not have achieved its wide use today," he wrote. "...Addressing crash issues is a top priority in the engineering team, and currently there are open reports we are researching in Flash Player 10. From the comments across the Web there may either be an upswing in incidents or there is a general piling on happening -- we are looking into this actively and will work to resolve any real issues."

Adobe last year made a commitment to improve its security processes, but not everyone believes the company has done enough.

Comment  | 
Print  | 
More Insights
Comments
Threaded  |  Newest First  |  Oldest First
Four Faces of Fraud: Identity, 'Fake' Identity, Ransomware & Digital
David Shefter, Chief Technology Officer at Ziften Technologies,  6/14/2018
Meet 'Bro': The Best-Kept Secret of Network Security
Greg Bell, CEO, Corelight,  6/14/2018
Containerized Apps: An 8-Point Security Checklist
Jai Vijayan, Freelance writer,  6/14/2018
Register for Dark Reading Newsletters
White Papers
Video
Cartoon
Current Issue
Flash Poll
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2018-9036
PUBLISHED: 2018-06-20
CheckSec Canopy 3.x before 3.0.7 has stored XSS via the Login Page Disclaimer, allowing attacks by low-privileged users against higher-privileged users.
CVE-2018-12327
PUBLISHED: 2018-06-20
Stack-based buffer overflow in ntpq and ntpdc of NTP version 4.2.8p11 allows an attacker to achieve code execution or escalate to higher privileges via a long string as the argument for an IPv4 or IPv6 command-line parameter. NOTE: It is unclear whether there are any common situations in which ntpq ...
CVE-2018-12558
PUBLISHED: 2018-06-20
The parse() method in the Email::Address module through 1.909 for Perl is vulnerable to Algorithmic complexity on specially prepared input, leading to Denial of Service. Prepared special input that caused this problem contained 30 form-field characters ("\f").
CVE-2018-6563
PUBLISHED: 2018-06-20
Multiple cross-site request forgery (CSRF) vulnerabilities in totemomail Encryption Gateway before 6.0.0_Build_371 allow remote attackers to hijack the authentication of users for requests that (1) change user settings, (2) send emails, or (3) change contact information by leveraging lack of an anti...
CVE-2018-1120
PUBLISHED: 2018-06-20
A flaw was found affecting the Linux kernel before version 4.17. By mmap()ing a FUSE-backed file onto a process's memory containing command line arguments (or environment strings), an attacker can cause utilities from psutils or procps (such as ps, w) or any other program which makes a read() call t...