Risk
2/11/2010
06:18 PM
Connect Directly
Google+
LinkedIn
Twitter
RSS
E-Mail
50%
50%

Adobe Flash, Reader, Acrobat Vulnerable

The company has issued fixes for two vulnerabilities, but a third set of flaw affecting Reader and Acrobat won't be patched until next week.

Adobe on Thursday issued two security bulletins to address vulnerabilities in its Flash Player software and in its LiveCycle and ColdFusion software.

It also issued a security advisory about vulnerabilities in its Reader and Acrobat software that will be addressed in a patch next week.

The Flash Player vulnerability is designated "critical" and affects version 10.0.42.34 and earlier. Flash Player 10.0.45.2 resolves the issue and is available for download.

The vulnerability affecting LiveCycle 9.0, 8.2.1 and 8.0.1, and ColdFusion 9.0, 8.0.1, 8.0 and 7.0.2, resides in the BlazeDS 3.2 component, or earlier, and has been rated "important." Adobe has posted fix details on its Web site.

Adobe's advisory warns of "critical" flaws in Reader 9.3 for Windows, Macintosh and UNIX, Acrobat 9.3 for Windows and Macintosh, and Reader 8.2 and Acrobat 8.2 for Windows and Macintosh.

"This vulnerability (CVE-2010-0186) could subvert the domain sandbox and make unauthorized cross-domain requests," Adobe's advisory says.

Adobe plans to make a fix available on February 16.

The vulnerabilities come at an awkward time for Adobe. This is the third month in a row that the company has issued critical security advisories for its Reader and Acrobat software. Its Flash technology was recently panned by Apple CEO Steve Jobs, who reportedly said that when Macs crash, Flash is usually the cause.

Adobe CTO Kevin Lynch posted a lengthy defense of his company's technology and, following a flurry of critical comments from readers, continued that defense in an additional comment post.

"I can tell you that we don't ship Flash with any known crash bugs, and if there was such a widespread problem historically Flash could not have achieved its wide use today," he wrote. "...Addressing crash issues is a top priority in the engineering team, and currently there are open reports we are researching in Flash Player 10. From the comments across the Web there may either be an upswing in incidents or there is a general piling on happening -- we are looking into this actively and will work to resolve any real issues."

Adobe last year made a commitment to improve its security processes, but not everyone believes the company has done enough.

Comment  | 
Print  | 
More Insights
Register for Dark Reading Newsletters
White Papers
Cartoon
Current Issue
Flash Poll
Video
Slideshows
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2013-6501
Published: 2015-03-30
The default soap.wsdl_cache_dir setting in (1) php.ini-production and (2) php.ini-development in PHP through 5.6.7 specifies the /tmp directory, which makes it easier for local users to conduct WSDL injection attacks by creating a file under /tmp with a predictable filename that is used by the get_s...

CVE-2014-9209
Published: 2015-03-30
Untrusted search path vulnerability in the Clean Utility application in Rockwell Automation FactoryTalk Services Platform before 2.71.00 and FactoryTalk View Studio 8.00.00 and earlier allows local users to gain privileges via a Trojan horse DLL in an unspecified directory.

CVE-2014-9652
Published: 2015-03-30
The mconvert function in softmagic.c in file before 5.21, as used in the Fileinfo component in PHP before 5.4.37, 5.5.x before 5.5.21, and 5.6.x before 5.6.5, does not properly handle a certain string-length field during a copy of a truncated version of a Pascal string, which might allow remote atta...

CVE-2014-9653
Published: 2015-03-30
readelf.c in file before 5.22, as used in the Fileinfo component in PHP before 5.4.37, 5.5.x before 5.5.21, and 5.6.x before 5.6.5, does not consider that pread calls sometimes read only a subset of the available data, which allows remote attackers to cause a denial of service (uninitialized memory ...

CVE-2014-9705
Published: 2015-03-30
Heap-based buffer overflow in the enchant_broker_request_dict function in ext/enchant/enchant.c in PHP before 5.4.38, 5.5.x before 5.5.22, and 5.6.x before 5.6.6 allows remote attackers to execute arbitrary code via vectors that trigger creation of multiple dictionaries.

Dark Reading Radio
Archived Dark Reading Radio
Good hackers--aka security researchers--are worried about the possible legal and professional ramifications of President Obama's new proposed crackdown on cyber criminals.