Attacks/Breaches
10/27/2010
11:56 AM
50%
50%

Iranian Cyber Army Joins Botnet Business

Up to 20 million machines may be infected by malware network, which may be backed by Iranian authorities, finds Seculert.

Inside DHS' Classified Cyber-Coordination Headquarters
(click image for larger view)
Slideshow: Inside DHS' Classified Cyber-Coordination Headquarters
The Iranian Cyber Army (ICA), known for defacing websites, appears to be diversifying. Security researchers now say the group is responsible for a powerful, recently discovered botnet containing more than 400,000 infected computers, and adding new ones at the rate of 14,000 every hour.

"It appears reasonable to assume that the 'Iranian Cyber Army' group has decided to move from simple defacement warnings to actual cybercrime activities," said Seculert, the threat management service that discovered the botnet. In fact, the botnet may have already infected 20 million machines, though Seculent said that number was an estimate.

"What really matters here is what the 'Iranian Cyber Army' can do with such power," said the firm. "For now, what they do is lease part of their botnet to other groups, which then install on these controlled machines different types of malware." That malware includes Zeus, Gozi, and Bredolab. (While Dutch police took down a number of Bredolab servers early this week, TrendMicro noted that at least one command-and-control server, located outside the Netherlands, is still active, and there may be more.)

Seculert has already traced multiple attacks to the Iranian Cyber Attack's botnet, including the September 2010 attack against the TechCrunch Europe blog site. After the attack, the TechCrunch website redirected users to a crimeware website that exploited known vulnerabilities to automatically install malware on the visitor's computer.

"What is interesting in the case of ICA is that they were the ones performing the attack, said Rob Rachweld, director of security strategy at Imperva. "Now they have realized -- why can't they make the extra buck on the side if they already have the infrastructure?"

The exact identities of the Iranian Cyber Army are in some dispute, though news reports suggest that the group was formed by Iranian authorities in the wake of mass protests -- physical and cyber -- following the disputed June 2009 Iranian presidential elections.

Comment  | 
Print  | 
More Insights
Register for Dark Reading Newsletters
White Papers
Cartoon
Current Issue
Dark Reading December Tech Digest
Experts weigh in on the pros and cons of end-user security training.
Flash Poll
Video
Slideshows
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2014-7830
Published: 2014-11-24
Cross-site scripting (XSS) vulnerability in mod/feedback/mapcourse.php in the Feedback module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 allows remote authenticated users to inject arbitrary web script or HTML by leveraging the mod/feedback:mapcourse cap...

CVE-2014-7831
Published: 2014-11-24
lib/classes/grades_external.php in Moodle 2.7.x before 2.7.3 does not consider the moodle/grade:viewhidden capability before displaying hidden grades, which allows remote authenticated users to obtain sensitive information by leveraging the student role to access the get_grades web service.

CVE-2014-7832
Published: 2014-11-24
mod/lti/launch.php in the LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 performs access control at the course level rather than at the activity level, which allows remote authenticated users to bypass the mod/lti:view capability requirement by vi...

CVE-2014-7833
Published: 2014-11-24
mod/data/edit.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 sets a certain group ID to zero upon a database-entry change, which allows remote authenticated users to obtain sensitive information by accessing the database after an edit by a teacher.

CVE-2014-7834
Published: 2014-11-24
mod/forum/externallib.php in Moodle 2.6.x before 2.6.6 and 2.7.x before 2.7.3 does not verify group permissions, which allows remote authenticated users to access a forum via the forum_get_discussions web service.

Best of the Web
Dark Reading Radio
Archived Dark Reading Radio
Now that the holiday season is about to begin both online and in stores, will this be yet another season of nonstop gifting to cybercriminals?