Application Security
5/9/2013
01:43 PM
Connect Directly
Facebook
Google+
RSS
E-Mail
50%
50%
Repost This

Education Tech Vendors Launch Apps Contest

Learning management systems (LMS) vendors hope awards program will spur educational apps development.

12 Open Educational Resources: From Khan to MIT
12 Open Educational Resources: From Khan to MIT
(click image for slideshow)
Will cash prizes and bragging rights encourage software developers to build educational applications?

That's the hope of a group of learning management system (LMS) vendors, who have joined forces to announce an awards program at the IMS Global Learning Consortium Conference in San Diego, Calif., on Monday.

"Edtech isn't the ecosystem it should be," Brian Whitmer, co-founder and chief product officer at Instructure, maker of the Canvas LMS, told InformationWeek in a phone interview. "It's too hard for new entrants to get in."

Along with LMS makers Blackboard and Desire2Learn, Instructure wants to encourage developers to use the IMS' Learning Tools Interoperability (LTI) standard for building applications. The awards program is a way to promote LTI.

[ Want more on Canvas? Read Canvas LMS Maker Launches Open Education Apps Directory. ]

Under the LTI Apps Bounty, any qualifying app will receive $250; winners will receive an additional $1,000. Winners will be announced on June 20.

LTI is a specification that seeks to establish a standard way of integrating learning applications with platforms such as learning management systems, portals or other educational environments. In LTI parlance, learning applications are called "tools" and the learning management system is the "tool consumer." For example, Canvas is written in Ruby, Blackboard is written in Java and Desire2Learn is built in the .NET Framework -- but all of these "tool consumers" can use LTI-compliant "tools."

IMS Global hosts a catalog of LTS-compatible software and platforms here.

"Yes, there are barriers to entry [in the education software market] and providing financial incentives to enter is a good idea," Benjamin Jones, an associate professor at Kellogg School of Management and faculty director of the Kellogg Innovation and Entrepreneurship Initiative (KIEI), said in a phone interview.

But Jones went on to say schools and school districts won't buy software until they are convinced about the effectiveness of these applications. "There's still a challenge proving these products work," he said.

Jones, along with Duke University business professor Aaron Chatterji, is building Edu Star, a cloud-based platform that will, among other things, offer empirical rankings of educational software.

To get the word out about the awards, the companies are alerting their respective developer communities, school customers and social media channels. Details about the awards program -- including submission and judging criteria, as well as a submission form -- are available here. All entries must be submitted by midnight Mountain Daylight Time on June 10.

Comment  | 
Print  | 
More Insights
Register for Dark Reading Newsletters
White Papers
Flash Poll
Current Issue
Video
Slideshows
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2008-3277
Published: 2014-04-15
Untrusted search path vulnerability in a certain Red Hat build script for the ibmssh executable in ibutils packages before ibutils-1.5.7-2.el6 in Red Hat Enterprise Linux (RHEL) 6 and ibutils-1.2-11.2.el5 in Red Hat Enterprise Linux (RHEL) 5 allows local users to gain privileges via a Trojan Horse p...

CVE-2010-2236
Published: 2014-04-15
The monitoring probe display in spacewalk-java before 2.1.148-1 and Red Hat Network (RHN) Satellite 4.0.0 through 4.2.0 and 5.1.0 through 5.3.0, and Proxy 5.3.0, allows remote authenticated users with permissions to administer monitoring probes to execute arbitrary code via unspecified vectors, rela...

CVE-2011-3628
Published: 2014-04-15
Untrusted search path vulnerability in pam_motd (aka the MOTD module) in libpam-modules before 1.1.3-2ubuntu2.1 on Ubuntu 11.10, before 1.1.2-2ubuntu8.4 on Ubuntu 11.04, before 1.1.1-4ubuntu2.4 on Ubuntu 10.10, before 1.1.1-2ubuntu5.4 on Ubuntu 10.04 LTS, and before 0.99.7.1-5ubuntu6.5 on Ubuntu 8.0...

CVE-2012-0214
Published: 2014-04-15
The pkgAcqMetaClearSig::Failed method in apt-pkg/acquire-item.cc in Advanced Package Tool (APT) 0.8.11 through 0.8.15.10 and 0.8.16 before 0.8.16~exp13, when updating from repositories that use InRelease files, allows man-in-the-middle attackers to install arbitrary packages by preventing a user fro...

CVE-2013-4768
Published: 2014-04-15
The web services APIs in Eucalyptus 2.0 through 3.4.1 allow remote attackers to cause a denial of service via vectors related to the "network connection clean up code" and (1) Cloud Controller (CLC), (2) Walrus, (3) Storage Controller (SC), and (4) VMware Broker (VB).

Best of the Web