Perimeter
Guest Blog // Selected Security Content Provided By Sophos
What's This?
1/7/2013
08:55 AM
Dark Reading
Dark Reading
Security Insights
50%
50%

Another Zero-Day For Symantec PGP WDE

Symantec PGP Desktop is having a bumpy new year with a second zero-day vulnerability released in 13 days. Take action to protect your data

Thirteen days ago on Dec. 25, a security researcher named Nikita Tarakanov uncovered an arbitrary memory overwrite vulnerability in Symantec's PGP Desktop Whole Disk Encryption solution, according to this pastebin note. The pgpwded.sys version 10.2.0.2599 kernel driver distributed with Symantec PGP Desktop 10.2.0 Build 2599 (up to date) is vulnerable to malicious code execution in the handling of IOCTL 0x80022058.

Local access to the device is required in order to successfully exploit the vulnerability. Keeping that in mind, Symantec's response to Nikita via this blog posting states, "It's not of big concern as the stars need to be aligned for this to be exploited."

Nikita has been hard at work with a response to Symantec's blog posting and today unveiled an integer overflow vulnerability in the handling of IOCTL 0x80022094 within the pgpwded.sys kernel. You can read through the details in this pastebin note.

Once again, exploiting this new vulnerability is possible with arbitrary code execution, but requires local execution.

In the Twittersphere, Nikita has a tone of taunting dislike for Symantec with these tweets:

Nikita Tarakanov ‏@NTarakanov
This #0day affects all versions of Windows! Aligner of stars is counter-striking! :D

Nikita Tarakanov ‏@NTarakanov
Dirty PoC for Second #0day in Symantec PGP Desktop http://pastebin.com/W2VUMBJk You have to be able to align stars to exploit it! ;D

Nikita Tarakanov ‏@NTarakanov
Such lame vulns show: there is NO quality assurance in Symantec! #sad_but_true

Since it's still early in the morning at the time of this posting, there has been no response from Symantec yet. I can hardly blame the company, though: My gut tells me this has become personal and is not over yet. Symantec will need to choose its words more carefully to no longer feed the fire named Nikita.

Until Symantec releases a patch in February for the first vulnerability, the best way to protect your data in the meantime is to make sure you have PGP Desktop's Pre-Boot Authentication (PBA) enabled so that Windows doesn't load until after user authentication. In the event PBA is not enabled, make sure it becomes enabled today, and hope you don't lose any encrypted laptops with Symantec's PGP Desktop 10.2.0 Build 2599.

No security, no privacy. Know security, know privacy.

David Schwartzberg is a Senior Security Engineer at Sophos, where he specializes in the latest trends in malware, Web threats, endpoint and data protection, mobile security, and cloud and network security. He is a regular speaker at security conferences and serves as a guest blogger for the award winning Naked Security blog. David talks regularly with technology executives and professionals to help protect their organizations against the latest security threats. Follow him on Twitter @DSchwartzberg

Comment  | 
Print  | 
More Insights
Register for Dark Reading Newsletters
White Papers
Cartoon
Current Issue
Dark Reading December Tech Digest
Experts weigh in on the pros and cons of end-user security training.
Flash Poll
Title Partner’s Role in Perimeter Security
Title Partner’s Role in Perimeter Security
Considering how prevalent third-party attacks are, we need to ask hard questions about how partners and suppliers are safeguarding systems and data.
Video
Slideshows
Twitter Feed
Dark Reading - Bug Report
Bug Report
Enterprise Vulnerabilities
From DHS/US-CERT's National Vulnerability Database
CVE-2014-7830
Published: 2014-11-24
Cross-site scripting (XSS) vulnerability in mod/feedback/mapcourse.php in the Feedback module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 allows remote authenticated users to inject arbitrary web script or HTML by leveraging the mod/feedback:mapcourse cap...

CVE-2014-7831
Published: 2014-11-24
lib/classes/grades_external.php in Moodle 2.7.x before 2.7.3 does not consider the moodle/grade:viewhidden capability before displaying hidden grades, which allows remote authenticated users to obtain sensitive information by leveraging the student role to access the get_grades web service.

CVE-2014-7832
Published: 2014-11-24
mod/lti/launch.php in the LTI module in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 performs access control at the course level rather than at the activity level, which allows remote authenticated users to bypass the mod/lti:view capability requirement by vi...

CVE-2014-7833
Published: 2014-11-24
mod/data/edit.php in Moodle through 2.4.11, 2.5.x before 2.5.9, 2.6.x before 2.6.6, and 2.7.x before 2.7.3 sets a certain group ID to zero upon a database-entry change, which allows remote authenticated users to obtain sensitive information by accessing the database after an edit by a teacher.

CVE-2014-7834
Published: 2014-11-24
mod/forum/externallib.php in Moodle 2.6.x before 2.6.6 and 2.7.x before 2.7.3 does not verify group permissions, which allows remote authenticated users to access a forum via the forum_get_discussions web service.

Best of the Web
Dark Reading Radio
Archived Dark Reading Radio
Now that the holiday season is about to begin both online and in stores, will this be yet another season of nonstop gifting to cybercriminals?